برای طرح سوال و دسترسی به آموزش ها  کانال ما در تلگرام بپویندید  

نگاهی به لاراول ویرایش ۹

سلام تو این نوشته با هم میخوایم نگاهی بیندازیم به لاراول ۹

حداقل ورژن مورد نیاز php
لاراول از کتابخانه‌های سیمفونی زیاد استفاده می کند. در ورژن شماره ۹ لاراول از کتابخانه‌های سیمفونی ورژن ۶ استفاده شده و این کتابخانه‌ها حداقل ورژن مورد نیاز php رو ۸ قرار دادند بنابراین لاراول ویرایش ۹ نیاز به php ۸ دارد.


توابع استفاده از رشته
در لاراول ویرایش ۹ از توابع رشته های موجود در php ۸ استفاده میشه مثال str_contains(), str_starts_with()


نمایش بهتر دستور route:list
در لاراول اگر از دستور route:list استفاده می‌کردیم یه سری متن های تو در تو و شلخته می‌دیدیم. در ویرایش جدید این قسمت باز طراحی شده و یک نمایش بسیار تمیز تر از روت ها را شاهد هستیم.

دستور route:list در لاراول ۹


حذف فایل server.php

همواره در روت پروژه لاراول یک فایل با نام server.php وجود داشت در نسخه جدید این فایل رو شما میتونید حذف کنید.


تاریخ انتشار

 تاریخ انتشار لاراول ویرایش ۹ برای بهمن ماه سال ۱۴۰۰ در نظر گرفته شده است. در زمان انتشار این پست این ویرایش در مرحله RC قرار داشت و اکثر پکیج های معتبر اکوسیستم مانند پکیج های Spatie برای این نسخه تگ خورده است.

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد.

متنی که میخواهید برای جستجو وارد کرده و دکمه جستجو را فشار دهید. برای لغو دکمه ESC را فشار دهید.

بازگشت به بالا